MANTRA Chain Mainnet remains halted following the security incident reported earlier today. Transactions, transfers and staking operations are unavailable while the network is paused. User funds are unaffected by the halt itself, and a full network state snapshot was taken before the restart process began.
A patched release, v8.4.0, addresses the underlying vulnerability. The release is currently undergoing testing and due diligence on DuKong (Testnet). We are prioritising a careful, verified rollout over speed.
Next step: a coordinated Mainnet upgrade and restart, currently targeting later today, 21 August. This timing is subject to testing completing cleanly.
Validators: please keep Mainnet nodes offline until the coordinated restart is announced.
Identified
MANTRA Chain Mainnet remains halted following the security incident reported earlier today. Transactions, transfers and staking operations are unavailable while the network is paused. User funds are unaffected by the halt itself, and a full network state snapshot was taken before the restart process began.
A patched release, v8.4.0, addresses the underlying vulnerability. The release is currently undergoing testing and due diligence on DuKong (Testnet). We are prioritising a careful, verified rollout over speed.
Next step: a coordinated Mainnet upgrade and restart, currently targeting later today, 21 August. This timing is subject to testing completing cleanly.
Validators: please keep Mainnet nodes offline until the coordinated restart is announced.
Identified
Investigation update — MANTRA Chain remains Halted - Remedation and Testing in Progress
MANTRA Chain Mainnet remains halted. Earlier today we detected an attacker exploiting a vulnerability in an upstream dependency used by the chain, and halted the network as a precaution. The halt prevents transactions from being processed, so no assets can move on the network while it is in place.
We have identified the vulnerability and are proceeding to prepare a patched release. Our own validators and infrastructure are offline pending that upgrade, and resuming the network will require a coordinated restart with the wider validator set — we will not resume until the patch is verified and that coordination is in place.
Alongside this, we are tracing the movement of funds and are in contact with exchange partners. Deposits and withdrawals for MANTRA remain paused on affected venues until the chain resumes.
Our assessment of the full impact is ongoing and we are not yet in a position to confirm the complete scope. No action is required from users. Please rely only on official MANTRA channels, and be cautious of anyone offering "recovery" or "support" assistance.
A further update will follow at our next check-in.
Investigating
MANTRA Chain remains halted as a precaution while our team continues to investigate the incident. The halt prevents transactions from being processed, so no assets can move on the network while the investigation is ongoing.
Our engineering and security teams are working continuously alongside external partners. We will not resume the network until we are confident it is safe to do so.
We have notified exchange and ecosystem partners, and deposits and withdrawals for OM will remain paused on affected venues until the chain resumes. No action is required from users at this time — please rely only on official MANTRA channels for information, and be cautious of anyone offering "recovery" assistance.
A further update will follow, and we will continue posting at regular intervals until this is resolved.
Investigating
We're aware of an incident affecting MANTRA Chain and have halted the chain as a precaution while we investigate.
All endpoints and transactions are currently frozen. This means deposits and withdrawals to/from MANTRA Chain are temporarily affected.
If you're unsure how this impacts a specific transaction, please hold off until we share more. We don't have a root cause or timeline to share yet - we'll post here and on our official channels as soon as we have verified information.
Please rely only on official MANTRA channels for updates.
Investigating
MANTRA Chain has been halted and we are working to review the root cause and current impact of the incident in question, while we do this all endpoints and transactions on the chain are frozen. We will do our best to provide updates as quickly as possible